Subject: [tryton] Re: Starting Localizations

From: Cédric Krier <[email-masked]>
Date: Fri, 17 Oct 2008 11:48:00 +0200

On 16/10/08 05:57 -0500, Igor Támara wrote:
> I'm interested in constructing an accounting module for Colombia, 
> I would like to know if there is a schema or DTD to follow for 
> the xml file needed to import the chart of accounts to Tryton, for
> start with.

There is no schema specific for accounting but there is one general for
any xml file:

http://www.tryton.org/hgwebdir.cgi/trytond/file/tip/trytond/tryton.rnc

But it is planned to fix the account_be module and it will become a
example on how creating accounting module for country.

> An account module for a country has more than that, but
> beginning with it can start a path.

I think it is better to just create one module with only accounting
stuff for one country and no more.
Other speficiation must be done on other modules.

> 
> Maybe adding a date for freezing modules or accepting accounting
> modules, or a tutorial via chat to construct modules, some docs,
> would be nice.  If it's already something I can read, let me know.

The release process is independant for each modules. For the 17 nov, the
list of module that must be release has been set on
http://code.google.com/p/tryton/wiki/Release_1_0_0

> 
> I'm really happy right now on the ideas of the project and the
> process of quality it's having. The help through the chat and the
> docs constructed so far are clear and nice :)

Great, it is our goals :-)

> 
> All in all, thanks for all.
> 
> P.D:Maybe modules and docs are planned for post1.0 and I'm in a rush
> for things that can be done later, just let me know.
> 

For the release 1.0, we must provide the tools to write the
documentation for each modules and maybe one example of module
documentation.

-- 
Cédric Krier

B2CK SPRL
Rue de Rotterdam, 4
4000 Liège
Belgium
Tel: +32 472 54 46 59
Email: [email-masked]
Jabber: [email-masked]
Website: http://www.b2ck.com/

---

From: Igor Támara <[email-masked]>
Date: Thu, 16 Oct 2008 05:57:03 -0500

start with.  An account module for a country has more than that, but

-- 
Recomiendo Audacity para hacer edición de audio
http://audacity.sourceforge.net