Subject: [tryton] Re: Fedora packages for Tryton

From: Hartmut Goebel <[email-masked]>
Date: Sat, 22 Nov 2008 12:57:19 +0100

Dan Horák schrieb:

> That's not so simple - the first question was whether it is even
> allowed/expected by upstream authors. The second is related to
> filesystem standards - it is not allowed to have user modified files
> under /usr, so they would must be relocated to /etc, symlink them to
> original place to be found by the server, etc. And the count of them is
> quite high.

IC. I always thought bundling RPMs is an easy job, bit it seams as if it 
is not. Another topic to leave for the experts ;-)

-- 
Schönen Gruß - Regards
Hartmut Goebel
Dipl.-Informatiker (univ.), CISSP

Goebel Consult
Spezialist für IT-Sicherheit in komplexen Umgebungen
http://www.goebel-consult.de

---

From: Cédric Krier <[email-masked]>
Date: Fri, 21 Nov 2008 19:14:23 +0100

On 21/11/08 19:03 +0100, Dan Horák wrote:
> 
> > 
> > Normally, you don't have to modify the file installed. The way to
> > customize Tryton is by writing a modules or modify it with the client
> > (and it will be stored in the database)
> 
> Is inheritance between modules possible?
> 

Of course, you can inherit any model or wizard.
And so module can depend on other modules.

-- 
Cédric Krier

B2CK SPRL
Rue de Rotterdam, 4
4000 Liège
Belgium
Tel: +32 472 54 46 59
Email: [email-masked]
Jabber: [email-masked]
Website: http://www.b2ck.com/

---

From: Dan Horák <[email-masked]>
Date: Fri, 21 Nov 2008 19:03:14 +0100

Cédric Krier píše v Pá 21. 11. 2008 v 15:16 +0100:
> On 21/11/08 14:59 +0100, Dan Horák wrote:
> > 
> > > > - do you plan to move the *.svg pixmaps from /usr/share/pixmaps
> > > > into /usr/share/pixmaps/tryton?
> > > 
> > > Is it required? We prefix every file with tryton, is it not enough?
> > > Otherwise we can do it for the next major release.
> > > 
> > 
> > that's absolutely no requirement, the solution with prefix is good, but
> > it is usual that applications with large number of pixmaps use their own
> > subdirectory
> > 
> 
> We will do that for next major release
> 
> > > > 
> > > > modules
> > > > - what is the policy for customizing of the distributed modules or
> > > > adding new modules?
> > > 
> > > I don't understand.
> > > 
> > 
> > There are people (using tinyerp) that modify the xml and other "data"
> > files (rml, xsl, sxw, no *.py) to match the requirements in their
> > environments. But because these files are not marked as "config" files ,
> > they are overwritten when the package is updated. Only a file marked as
> > "config" can be updated without losing the user-made changes (you can
> > find *.rpmnew, *.rpmsave files in RPM based distros). It is a bigger
> > problem when monolithic packaging is used as in tinyerp, because one
> > update affects all files.
> > I don't know whether modifying the data files is compliant with your
> > implementation guidelines, but the solution looks quite simple to me -
> > the user will create a copy of the data file in separate directory
> > structure (e.g. in /var/lib/trytond/) and modify the file there. The
> > loader function will, when opening a data file, look into the
> > "user-modified" directory and when it is not there (= no modification
> > was done), it will load the default one.
> > 
> 

		Dan

--~--~---------~--~----~------------~-------~--~----~
[email-masked] mailing list
-~----------~----~----~----~------~----~------~--~---

---

From: Dan Horák <[email-masked]>
Date: Fri, 21 Nov 2008 18:23:59 +0100

Hartmut Goebel píše v Pá 21. 11. 2008 v 16:05 +0100:
> It's up do the package to make these files as config file, isn't it?!
> 

		Dan

---

From: Hartmut Goebel <[email-masked]>
Date: Fri, 21 Nov 2008 16:05:15 +0100

Goebel Consult

---

From: Cédric Krier <[email-masked]>
Date: Fri, 21 Nov 2008 15:16:18 +0100

> 
> So the conclusion for me is that the best packaging scheme would be to
> follow the upstream one = client, server and every module in a separate
> package.
> 

Good.

-- 
Cédric Krier

B2CK SPRL
Rue de Rotterdam, 4
4000 Liège
Belgium
Tel: +32 472 54 46 59

---

From: Dan Horák <[email-masked]>
Date: Fri, 21 Nov 2008 14:59:03 +0100

> > And now the questions:
> > client
> > - can you include a desktop file (see the URL above) into your sources?
> > It is installed in /usr/share/applications for all freedesktop.org
> > compliant desktop environment (GNOME, KDE, ...).
> 
> Ok, no problems like that we can also translated it.
> 

translations goes directly into the .desktop file, the standard is
located at
http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-1.0.html

> > 
> > server
> > - who cares about logfile rotation - is it trytond itself?
> 
> trytond rotates log file every day and keep 30 files.
> We will perhaps add configuration options in the futur.
> 

ok

> > - what is the minimal supported version of PostgreSQL? We have 8.1 in
> > Red Hat Enterprise Linux 5 and there will be no change until its EOL. I
> > would like add Tryton to RHEL/CentOS 5 via the EPEL add-on repository
> > derived from Fedora.
> 
> It works at least from the 8.0 (not tested previous one)
> 

8.0 is enough, there would be problems with too old python, etc. in
older RHEL/CentOS releases

> > Where they should live?
> 
> In trytond/modules, but the setup.py take care of that.
> (next release will allow installation with egg)
> 

ok

> > It is a plus point from the
> > packaging point of view that the modules are distributed independently
> > of the server.
> 
> I think yes. Because every module that is in the directory is loaded by
> the server even if the module is not enabled for the database. So
> installing only required modules will make the server starting faster,
> with less memory and less code (and so less bug :-).
> 
> > 
> > What will be the release policy for client, server and modules? Will
> > they be released individually or synchronized, what about their
> > versioning?
> > 
> 
> You can read http://code.google.com/p/tryton/wiki/ReleaseGeneral
> 
> But globally, we will have two kinds of release major and minor.
> Major release will be synchronized with client, server and modules.
> Minor release will be individually for only bug fix and there will be no
> change in the database (so no need of running the server with the update
> option)
> 

ok

		Dan

---

From: Cédric Krier <[email-masked]>
Date: Fri, 21 Nov 2008 13:09:01 +0100

On 21/11/08 12:29 +0100, Dan Horák wrote:
> 
> 
> Cédric Krier píše v Pá 21. 11. 2008 v 09:24 +0100:
> > On 21/11/08 08:02 +0100, Dan Horák wrote:
> > > 
> > > Hi,
> > > 
> > > I am already the package maintainer for tinyerp/openerp in Fedora and
> > > now I am going to package tryton for Fedora and maybe RHEL (via EPEL).
> > > So it is possible that I will have some questions or suggestions in the
> > > near future.
> > > 
> > 
> > No, problems.
> 
> You can find the preliminary paclages at http://fedora.danny.cz/tryton
> 

Great :-)

> > You can ask your questions here or on the irc channel #tryton on
> > freenode.
> 
> FYI - I am "sharkcz" on freenode
> 
> > You can find in http://hg.tryton.org/tryton-overlay ebuilds of Tryton
> > for Gentoo, if you want.
> > 
> 
> And now the questions:
> client

I don't understand.

-- 
Cédric Krier

B2CK SPRL
Rue de Rotterdam, 4
4000 Liège
Belgium
Tel: +32 472 54 46 59

---

From: Dan Horák <[email-masked]>
Date: Fri, 21 Nov 2008 12:29:11 +0100

And now the questions:
client

server

modules
- what is the policy for customizing of the distributed modules or
adding new modules? Where they should live? It is a plus point from the
packaging point of view that the modules are distributed independently
of the server.

	Thanks
		Dan

PS: I am a Red Hat employee and work on Fedora is a part of my tasks

---

From: Cédric Krier <[email-masked]>
Date: Fri, 21 Nov 2008 09:24:08 +0100

No, problems.

-- 
Cédric Krier

B2CK SPRL
Rue de Rotterdam, 4
4000 Liège
Belgium
Tel: +32 472 54 46 59

---

From: Dan Horák <[email-masked]>
Date: Fri, 21 Nov 2008 08:02:08 +0100

Hi,

		Dan

-- 
Fedora and Red Hat package maintainer