Subject: [tryton] Re: Administration Menu

From: mb <[email-masked]>
Date: Sun, 31 Aug 2008 06:40:09 -0700 (PDT)

I appreciate clear structured and intuitive menus, at the moment the
items are rather  spread in different places. Here are my porposals:

Client menu:
We have User/Preferences and Options
I would favor to put User/Preferences under Options/Preferences (to
have them at one place) and rename User to Requests
typos: File/Databases -> File/Database, User/Waiting Requests ->
Waiting requests
There is no clear general handling of composed terms in menus,
sometimes it is "Capital Capital", sometimes "Capital small": I would
favor Capital always.

Application menu:
Here I would also prefer to join all administration items in one
place. Financial management/Configuration thus should be placed under
Administration.
Rename IR/Res/UI to some more meaningful like General/Users/Appearance
or User Interface
Translations should be (according to the rest of the menu structure)
rather be a folder containing these items like Modules
I probably would remove IR at all in favor of some more specific items
(sorted alpahabetically) i. e.:

Actions
     Actions
     Reports
     ...
     Scheduled Actions

General
      Sequences
      Models
      Fields
      Attachments
      Properties
      Defaults
      ...

Localization
       Translation
              Translations
              Update Report Translations
              ...
       Languages
       Countries

Permissions
      Models Access

User Interface
       ...

System
      Modules
           Install _/_ Upgrade Modules

WebDAV
     ...

Workflow
     ...

On 29 Aug., 21:39, Cédric Krier <[email-masked]> wrote:
> Hi, I would like to review the Administration Menu.
> We first follow the structure of the modules and object but I don't find
> it is really usefull.
> I would like to hear your opinion about this menu.
> I think webdav and workflow are good but the ir and res folders are not
> very clear.
>
> --
> Cédric Krier
>
> B2CK sprl
> Rue de Rotterdam, 4
> 4000 Liège
> Belgium
> Tel: +32 472 54 46 59
> Email: [email-masked]
> Jabber: [email-masked]
> Website:http://www.b2ck.com/
>
>  application_pgp-signature_part
> < 1KViewDownload
--~--~---------~--~----~------------~-------~--~----~
[email-masked] mailing list
-~----------~----~----~----~------~----~------~--~---

---

From: Cédric Krier <[email-masked]>
Date: Fri, 29 Aug 2008 21:39:46 +0200

-- 
Cédric Krier

B2CK sprl
Rue de Rotterdam, 4
4000 Liège
Belgium
Tel: +32 472 54 46 59
Email: [email-masked]
Jabber: [email-masked]
Website: http://www.b2ck.com/