Subject: [tryton] Re: AW: [tryton] Release strategy

From: Cédric Krier <[email-masked]>
Date: Mon, 23 Jun 2008 12:06:30 +0200

On 22/06/08 20:41 +0200, Korbinian Preisler wrote:
> Hi Cedric,
> 
> sounds good.
> 
> I think we need a estimated timetable for this process and
> we should define in detail which documentation is needed for
> a module.

I think one month for testing modules must be enough.
And one week to finish translations.
And one month of release candidate.

So all the process will take 9 weeks.

The documentation depends of the module and I think it must be as more
as possible complete. But I don't think it must avoid releasing.

-- 
Cédric Krier

B2CK sprl
Rue de Rotterdam, 4
4000 Liège
Belgium
Tel: +32 472 54 46 59
Email: [email-masked]
Website: http://www.b2ck.com/

---

From: "Korbinian Preisler" <[email-masked]>
Date: Sun, 22 Jun 2008 20:41:42 +0200

Hi Cedric,

sounds good.

Best wishes,

Korbinian

-----Ursprüngliche Nachricht-----
Von: [email-masked] im Auftrag von Cédric Krier
Gesendet: Do 19.06.2008 23:30
An: [email-masked]
Betreff: [tryton] Release strategy

I think a good strategy for release is like OpenBSD.
It is based on fixed date release (2 per year).
I don't know if 2 releases per year is good.

To be able to have fixed date release, we need a strategy to stabilize
the software for the date. So I propose something like that:

- We stop the development on the framework at a date pre-defined
  (depending of the release date). So we create a branch of the current
  tips.

- All leaders of each modules must take care that his module works correctly with the
  fixed framework. Once a module is working, we create a branch for this
  one. And we fixed a deadline to have all the modules working otherwize
  others can take the leadership of the module.
  We must also check that the documentation is always up-to-date.

- When a module is branches, the translations teams can start to fix the
  translation.

- When each modules are branched, we start creating release candidate
  and ask the community to test it.

- At the date, normally all is working :-) and we can make the release.

-- 
Cédric Krier

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "Tryton" group.
To post to this group, send email to [email-masked]
To unsubscribe from this group, send email to [email-masked]
For more options, visit this group at http://groups.google.com/group/tryton?hl=en
-~----------~----~----~----~------~----~------~--~---